1100 zxi first ride - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
http://www.pwcforum.com
 
Go Back   PWC Forum: The best hang-out for Personal WaterCraft enthusiasts > PWC Jetski Specific Forums > Kawasaki Jetski


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 04-25-2009, 09:18 PM   #1 (permalink)
Junior Member
 
Join Date: Apr 2009
Posts: 2
Default 1100 zxi first ride

I purchased a '98 1100 zxi and got to ride it for the first time today. It didn't seem to want to get over 6200-6500 RPM, is this normal? I thought it was going to be a little faster than what it is. I don't know how fast I was going b/c the speedometer wasn't working today for some reason. I'm guessing 45-50 mph. It also seems a little slugish off the line. Once it planes it takes off pretty well. I've checked compression, and it was 105-110 on all three cylinders. It is lower than everyones norm of 120 but it is above Kawasaki manual of minimum of 95psi, so I guess it is ok. Some people have reported similar problems and said they cut the end off their spark plug wire to get to a newer piece of the wire, how do you do that? Do you have to open the electronics box?

One other thing, it seems to porpoise quite easy, is there a way to fix that? Rideplate perhaps? How many MPH would an aftermarket head give me?

Sorry for all the questions!

Thanks for your help!
runyonwc is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-13-2009, 10:26 PM   #2 (permalink)
Junior Member
 
Join Date: Aug 2009
Posts: 15
Default

im having almost the same problem only thing is its just the speedometer isnt working. how do i go fixing it? what might be broken and where can i find a replacement?
my tac works just fine.
wendeln16 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:27 PM.




SEO by vBSEO 3.6.0