91 550sx fuel problems - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-15-2017, 02:04 PM Thread Starter
Junior Member
 
Join Date: May 2017
Posts: 3
91 550sx fuel problems

Hi,

I'm having some trouble with my 550sx.

When I was riding the other day, I stopped to take a break and afterwards I was unable to restart the ski. It didn't bog down while riding!

Once home I started to investigate:

- I have spark (nice blue ones)
- I have compression 125psi and 120psi
- The fuel reaches the carb (i have installed a clear line and I can see it sucking up fuel)
- It starts if i pore some gas straight into the carb and then dies 10 seconds later. In those 10 seconds it responds to the throttle as nothing is wrong.

Since I thought it must be the carb i orderd a rebuild kit. Still this makes no difference.
I also used fresh fuel as i thought there could be water in the tank.

I have now come to the point were i need some advice, I was hoping to get it here.

Anyone who can help me ?

Thanks!
RobinL is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-16-2017, 05:36 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Posts: 2,799
Garage
Sounds like no fuel is getting past the inlet screen or needle valve is stuck. Did you change the screen and blow all the circuits out ?
rodsatheart is online now  
post #3 of 5 (permalink) Old 05-16-2017, 03:00 PM Thread Starter
Junior Member
 
Join Date: May 2017
Posts: 3
I cleaned the inlet screen and replaced the needle when I installed the rebuild kit. Today I noticed that the spring that came with the rebuild kit is a bit stiffer than the one I replaced.
I will try again with the original spring tomorrow.
RobinL is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-16-2017, 06:05 PM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Posts: 2,799
Garage
That spring sets the pop off pressure and should only be changed if the pop off is wrong or the spring is lost, then must replace it with the same color spring and verify the pop off.
rodsatheart is online now  
post #5 of 5 (permalink) Old 05-17-2017, 04:05 PM Thread Starter
Junior Member
 
Join Date: May 2017
Posts: 3
I used the old needle and spring and at first it didn't work. Then i bended the float arm a tiny bit and now it seems to work perfectly. Thank you for steering me towards the pop off valve !!
RobinL is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome