95 monte carlo 640 top speed - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
http://www.pwcforum.com
 
Go Back   PWC Forum: The best hang-out for Personal WaterCraft enthusiasts > PWC Jetski Specific Forums > Tigershark Jetski


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 05-28-2012, 06:42 PM   #1 (permalink)
Senior Member
 
Watershark's Avatar
 
Join Date: Sep 2011
Location: Kentucky
Posts: 239
Default 95 monte carlo 640 top speed

I have a 95 Monte Carlo 640. new rings and crank this year. 150 psi compression on both cylinders. I feel like I hit a wall at 40 mph. it won't go faster. This is with me alone or with 3 people on, it runs the same speed. propping it up seems of the question because full loaded it takes full throttle to put it on plane. after that 1/3 throttle will hold 35 and full only gets you 40. I have the carb set at factory specs. What I want to know is what is normal on a Monte Carlo this is my first Tigershark I'm not sure what to expect.

here is a video from a month ago.


Last edited by Watershark; 05-28-2012 at 06:52 PM.
Watershark is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-31-2012, 10:33 PM   #2 (permalink)
Senior Member
 
Watershark's Avatar
 
Join Date: Sep 2011
Location: Kentucky
Posts: 239
Default

I saw where some one was talking about rebuilding the carb on one of these tigersharks and the mentioned checking the pop off valve in the carb. Is this like a power valve on a holley carb? Where is the pop off valve located. and how do I test it?
Watershark is offline   Reply With Quote
Old 06-04-2012, 09:25 PM   #3 (permalink)
Senior Member
 
Watershark's Avatar
 
Join Date: Sep 2011
Location: Kentucky
Posts: 239
Default

allright yesterday I installed a new tachometer. I've got the carb set to factory specs. 6500 rpms W.O.T. It will rev to 6000 when I take off from a dead stop and then to 6500 after it planes out. My repair manual says 6900 is where I should be at when at full throttle. Any Idea's? do I need to lean it out more. anything under 5500 and it will randomly miss from time to time. Also it fouls plugs if you don't keep the revs up. factory specs call for 1 turn on the high speed needle. that's where it is setting. I'm afraid of leaning it out in fear of burning a hole in the piston. plugs are oe equivalent and I am still running the oil injection. I synchronized the oil pump (adjusted the cable so the marks line up on the arm) when I rebuilt the engine. Can I lean it out without burning up pistons, if so how much. I am afraid to idle very long because it will load up. It's hard to start. Every time you have to "play" with the throttle to get it to start.
Watershark is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 10:41 AM.




SEO by vBSEO 3.6.0