cooling system - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
http://www.pwcforum.com
 
Go Back   PWC Forum: The best hang-out for Personal WaterCraft enthusiasts > PWC Jetski Specific Forums > Yamaha Jetski


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 10-30-2012, 06:22 AM   #1 (permalink)
Junior Member
 
Join Date: Oct 2012
Posts: 1
Default cooling system

I have a 2008 Yamaha waverunner. I am concerned since the outflow at the back is rather slow. I cheched the inlet and impeller and did not find obvious problems. It performs well and do not over heat. Should I be concerned?
Gerrie07 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-30-2012, 07:13 AM   #2 (permalink)
Senior Member
 
xxMoving Target's Avatar
 
Join Date: May 2012
Location: South East
Posts: 187
Default

One in the back has nothing to do with cooling, the one on side of ski is the cooling outlet, see if the hose under the rear deck is crimped or if previous owner tried to block it off. It's only for visual safety, a lot people block them off when pulling tubes.
xxMoving Target is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:57 AM.




SEO by vBSEO 3.6.0