90 Yamaha superjet 650 - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
http://www.pwcforum.com
 
Go Back   PWC Forum: The best hang-out for Personal WaterCraft enthusiasts > PWC Jetski Specific Forums > Yamaha Jetski


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 12-11-2012, 03:47 PM   #1 (permalink)
Junior Member
 
Join Date: Dec 2012
Posts: 1
Default 90 Yamaha superjet 650

What would make my ski not pump water through the cooling system? Please help just want to ride
yjeremy444 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-11-2012, 06:26 PM   #2 (permalink)
Senior Member
 
Ernest T's Avatar
 
Join Date: Aug 2009
Location: Woods on the left past Mayberry
Posts: 2,747
Default

Easiest thing would be that the inlet is clogged with weeds or other debris. Take a good look around the inlet (it will be near the impeller) to see if it is blocked. If you are not getting flow while its on the hose, then you may have a blockage in the cooling system, which could be a lot harder to locate and fix.
__________________
2008 Yamaha FX HO Cruiser
2010 Hurricane Sundeck 2100
Ernest T is online now   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:49 PM.




SEO by vBSEO 3.6.0