2004 FX HO won't start. - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
http://www.pwcforum.com
 
Go Back   PWC Forum: The best hang-out for Personal WaterCraft enthusiasts > PWC Jetski Specific Forums > Yamaha Jetski


» Sponsors





Reply
 
LinkBack Thread Tools Display Modes
Old 01-20-2013, 08:05 PM   #1 (permalink)
Junior Member
 
Join Date: Nov 2012
Posts: 14
Default 2004 FX HO won't start.

I have swapped the engine in my 2004 ski from 2006, reconnected the sensors and connected battery but it wouldn't start.
The battery seems to be strong as the engines turns just fine. When I connect battery I see briefly security light on for a few seconds and then off , the dash does not display anything.
The fuses are all good.
Please, advise what is wrong, what should I check?
folush is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-20-2013, 08:42 PM   #2 (permalink)
Senior Member
 
Ernest T's Avatar
 
Join Date: Aug 2009
Location: Woods on the left past Mayberry
Posts: 2,767
Default

The ECU is a different part number on those 2 model years. You will probably need to swap out the ECU from the other ski as well as the wiring harness which is also a different part number from the 04. I'd probably try just the ECU 1st, since the wiring harness is more of a PITA to do.
__________________
2008 Yamaha FX HO Cruiser
2010 Hurricane Sundeck 2100
Ernest T is online now   Reply With Quote
Old 01-21-2013, 10:15 AM   #3 (permalink)
Junior Member
 
Join Date: Nov 2012
Posts: 14
Default

Thank you Ernest for a quick reply,
The ECU and harness are quite expensive, I was trying to explore other options. It seems that someone was able to swap engine from 2007 FX HO to his 2005 FX HO:
http://www.pwcforum.com/yamaha-jetsk...html#post39461
MY main concern is the dashboard,as it is completely dead.
I was hoping to get some fault codes on it.
What should I start checking, to see why the dashboard is not operational?
Could it be bad rectifier?
On the connector I can see that the dielectric grease is light green as it's mixed with copper oxide.

Last edited by folush; 02-04-2013 at 03:48 PM.
folush is offline   Reply With Quote
Old 05-21-2013, 12:58 PM   #4 (permalink)
Junior Member
 
Join Date: Nov 2012
Posts: 14
Default

Quote:
Originally Posted by Ernest T View Post
The ECU is a different part number on those 2 model years. You will probably need to swap out the ECU from the other ski as well as the wiring harness which is also a different part number from the 04. I'd probably try just the ECU 1st, since the wiring harness is more of a PITA to do.
Ernest, is there a possibility that the existing harness will destroy the new ECU? I think I also will have to replace the instrument control panel?

Last edited by folush; 05-21-2013 at 12:59 PM. Reason: grammar errors
folush is offline   Reply With Quote
Old 05-21-2013, 06:12 PM   #5 (permalink)
Senior Member
 
Ernest T's Avatar
 
Join Date: Aug 2009
Location: Woods on the left past Mayberry
Posts: 2,767
Default

I don't think the wiring harness will cause any damage, but if you use the wrong wiring harness with the ECU you may still get a "dead" reading. Usually the differences in the wiring harnesses are just a couple of wires from year to year.
__________________
2008 Yamaha FX HO Cruiser
2010 Hurricane Sundeck 2100
Ernest T is online now   Reply With Quote
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:14 AM.




SEO by vBSEO 3.6.0