Overheat with flushing - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-19-2019, 12:01 AM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 4
Overheat with flushing

First voyage on new ski.

Took the ski out and had a great time. Got home and flushed out with fresh water. Switched to flush with salt away and immediately starts smoking and warning light sounds. I shut off water and motor and let sit. 90 minutes later I go start it, starts right up but warning still sounding. Did I mess something up? Or just wait until morning and start it up again then?

Thanks for help in advance

2018 Yamaha FXHO
gatordragon is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-19-2019, 06:07 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,889
Dock
Almost sounds like not enough water flow. Try it again in the morning.
rodsatheart is online now  
post #3 of 6 (permalink) Old 02-19-2019, 01:14 PM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 4
Went to service, all checked out good. probably water flow issue.
gatordragon is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 02-19-2019, 01:15 PM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 4
Thanks it was as you thought it seems.
gatordragon is offline  
post #5 of 6 (permalink) Old 02-20-2019, 04:42 PM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,889
Dock
Good deal.
rodsatheart is online now  
post #6 of 6 (permalink) Old 04-18-2019, 08:54 AM
Senior Member
 
Lee Taylor's Avatar
 
Join Date: Oct 2011
Location: Charleston SC
Posts: 583
Water flow rate too slow was my first thought also

Owner. Rider. Maintenance. 17yrs.
2002 Yamaha. FX140. 1000cc. Cruiser. Collectors model.
2017 Lowes Stryker 16. Mercury 50hp 4-stroke.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Lee Taylor is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Wave Raider question - false overheat indicator on re-start Youdog99 Yamaha Jetski 5 07-16-2009 08:23 AM
650sx overheat Kaw650sx Vintage Jetski 1 06-05-2009 09:27 PM
650sx overheat Kaw650sx Vintage Jetski 0 06-02-2009 09:40 PM
does a 96 700 waveraider have overheat alarm? rhino_160 Yamaha Jetski 0 07-25-2008 11:14 PM
2003 waverunner overheat alarm derrick Yamaha Jetski 2 07-14-2008 10:18 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome