2012 Yamaha vx cruiser loss of 10 mph, engine humming noise - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-06-2019, 08:56 PM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 1
2012 Yamaha vx cruiser loss of 10 mph, engine humming noise

2012 Yamaha vx cruiser with loss of about 8-10 mph from top end, humming noise coming from engine, intermittent vibration like something is stuck in impeller. I removed the impeller completely and ran the engine, still get same humming noise and intermittent vibration from engine, spark plugs and compression to all cylinders good (175-180 psi), transfer case bearings are smooth and tight. I found that the silencer in the exhaust tube is blown out and the transfer drive gear has a bit of play in it (would this cause my symptoms, no signs of any metal filings in the transfer case or bottom of crankcase) Not sure where to go from here.
cellpro1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome