Low mph - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-20-2019, 01:49 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 1
Low mph

I have a 2007 F12X and at times the ski will run 60mph and sometimes it will only run 50mph. It doesn't seem to be misfiring and runs good otherwise. Does anyone else have this issue?
Dougnar is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-02-2019, 04:56 PM
Junior Member
 
vigilante397's Avatar
 
Join Date: Oct 2019
Location: Mojave Desert, CA
Posts: 11
Dock
Does it sound any different when it's running slower? Anything that sounds like the motor is straining, etc?



Side note: My skis are about 15 years older than yours and I can't even imagine going that fast, must be awesome

1993 Yamaha Waverunner III
1993 Yamaha Waverunner VXR

"Not a mechanic, not a complete idiot. Somewhere in the middle."
vigilante397 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome