05 STX 12 F weird stuff - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 06-14-2018, 07:38 AM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 9
05 STX 12 F weird stuff

Ok. I went out on my ski last week and everything was fine. I came home and flushed it out and stored it in my garage. Yesterday I changed the battery out and then tried to start it. It sounds like it is bogged down when starting and sounds like metal on metal grinding in the rear of the ski. It cranks 3 times and stops and then the power goes off and then on again all by itself. I checked the intake grate and it is not plugged up. Now it won’t crank at all. What is going on.
Jtzb03 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 06-14-2018, 08:59 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,808
Dock
Pump bearings might have gone out. Pull the pump and see what happens. Disconnect the fuel pump so it wont start when you turn it over.
rodsatheart is online now  
post #3 of 17 (permalink) Old 06-14-2018, 12:11 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 9
Now I can’t get the jet pump off. I have tried pulling prying banging 2x4 and everything. I think this was the problem all along. What you you thing. Maybe a bent shaft rod or impeller not on straight.
Jtzb03 is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 06-14-2018, 03:24 PM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,808
Dock
I believe there are 2 bolts that hol it to the ride plate. Did you get those also ?
rodsatheart is online now  
post #5 of 17 (permalink) Old 06-15-2018, 05:18 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,808
Dock
Is this a salt water or fresh water machine ?
rodsatheart is online now  
post #6 of 17 (permalink) Old 06-15-2018, 11:13 AM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 9
Yep. I took off the ride plate and all. I just can’t get this thing off. Is there something I am missing. Everything is unscrewed. Is it because it’s so jammed up that it won’t come off or do I have to go in the battery compartment and unscrew the 2 hose clamps on the drive shaft to see if the person before me jerry Rigged. It comes out about 2 inches and the drive shaft moves too. I see it going back and forth when I try to pull the pump off back and forth. I’m screwed aren’t I.
Jtzb03 is offline  
post #7 of 17 (permalink) Old 06-15-2018, 12:04 PM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,808
Dock
Sounds like the drive shaft is stuck in the impeller. It is just a slip spline fit and should slip apart. If you have a heat gun you can try and apply heat to the the impeller at the drive shaft but be carefull you dont get the hull to warm.
rodsatheart is online now  
post #8 of 17 (permalink) Old 06-15-2018, 12:47 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 9
I’ll try that. Thanks for all your help so far.
Jtzb03 is offline  
post #9 of 17 (permalink) Old 06-15-2018, 05:08 PM Thread Starter
Junior Member
 
Join Date: Jun 2018
Posts: 9
It still won’t come off. I give up. I have taken every option and tried it and it is being a pain in the azzzz. I don’t know if I should just take the whole engine out and start from scratch or just sell the dam thing.
Jtzb03 is offline  
post #10 of 17 (permalink) Old 06-15-2018, 06:20 PM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,808
Dock
Is there a driveshaft seal on the impeller and if so can you reach it to slide it back on the driveshaft. If so, spray some liquid wrench down in the impeller.
rodsatheart is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kawasaki 1100 stx weird problem Orangen1 Kawasaki Jetski 0 09-04-2014 11:10 PM
Shred Master Ride Plate KAWASAKI 1200 STX-R -12F -15F -09-12 STX Txstick PWC Jetski Classifieds 1 03-16-2014 10:33 AM
No Compression in One Cylinder/plus some other weird stuff ZackRB42 Yamaha Jetski 6 08-18-2012 02:52 PM
12.2......12.1......12.0 volts....kept dropping gregpwc Yamaha Jetski 3 04-15-2012 07:21 AM
05 f-12 non turbo need tech help or parts bmwtech Honda Jetski 0 03-04-2008 10:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome