2003 Virage - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 05-20-2019, 08:34 AM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 5
2003 Virage

Just picked the 03 Virage up to mess with, as it wasn't running from PO. This my 1st jet ski and after looking inside kinda lost. When I got home battery was @5 volts. No water so charged overnight and got up to 12 volts.
Went to try and start nothing so checked fuses 1 blown replaced now gauge lites up , no start just a click. Noticed the connector to the solenoid was lose but it just turns won't tighten.
Could that be the problem?
jterr is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 05-20-2019, 04:06 PM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,993
Dock
Check the voltage when trying to start it. Needs to be better than 10.5-11 when you hit the button. Is it a single click, or rapid clicking ?
rodsatheart is online now  
post #3 of 10 (permalink) Old 05-20-2019, 06:16 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 5
1click and like I said one of the connections on solenoid is loose and just spins when trying to tighten
jterr is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 05-20-2019, 06:27 PM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,993
Dock
Single click is prob because of the bad connection.
rodsatheart is online now  
post #5 of 10 (permalink) Old 05-20-2019, 06:30 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 5
Will have to replace as there is noway to get off without destroying. Thanks
jterr is offline  
post #6 of 10 (permalink) Old 05-21-2019, 04:53 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,993
Dock
It may be cross threaded. Try removing it with the cable, secure the relay to a bench, put a wrench on it, and hit the wrench with a hammer or something. The fast shock may loosen it. If not your going to have to cut the nut.
rodsatheart is online now  
post #7 of 10 (permalink) Old 05-30-2019, 07:09 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 5
Replaced the solenoid, battery cutoff and buttons on handle bar and got it to fire and ran just a bit. Question is now why is the Forward / Reverse lever so hard to move. It seems to be binding up. Where to check??
jterr is offline  
post #8 of 10 (permalink) Old 05-30-2019, 07:41 PM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,993
Dock
Prob the cable but i would lube all the pivot points first.
rodsatheart is online now  
post #9 of 10 (permalink) Old 05-30-2019, 09:23 PM Thread Starter
Junior Member
 
Join Date: May 2019
Posts: 5
Quote:
Originally Posted by rodsatheart View Post
Prob the cable but i would lube all the pivot points first.
Is there a diagram showing these, and how it is supposed to work?
Thanks
JT
jterr is offline  
post #10 of 10 (permalink) Old 05-31-2019, 04:42 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,993
Dock
Here's a great post about it. Look down a bit and there's step by step instructions.
How to repair a stiff/jammed Reverse lever on Virage, MSX, Genesis with reverse lever

Here's some more Polaris info that should interest you.
https://sites.google.com/site/polarispwcknowedge/Home
rodsatheart is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 virage i Oil Pump? Rhino99TJ Polaris Jetski 5 03-06-2017 06:14 AM
2003 Virage I Computer Module rickst1967 Polaris Jetski 0 07-12-2011 08:59 PM
2003 waverunner 1300gp & 2003 waverunner 800gp knarfoh Yamaha Jetski 0 08-23-2010 09:31 PM
2003 polaris Virage I weewun Polaris Jetski 2 06-21-2010 09:46 PM
2001 polaris virage trouble TRL24 Polaris Jetski 3 08-21-2006 10:33 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome