96 SLTX 1050 Starting Problems - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-19-2019, 09:07 PM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 2
Question 96 SLTX 1050 Starting Problems

Hello all,

A friend gave me a Polaris 96 SLTX as he was leaving town, I don't know the last time it was running but it's in rough shape. I got a new battery and tried to start it, I can hear the starter engage but the engine doesn't turn over. Where should I start troubleshooting?
Bochico is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-20-2019, 06:17 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 5,022
Dock
Pull the plugs and put about 3 table spoons of atf down the holes and let it sit. Next move will be to attempt to turn it over by hand somehow to make sure the engine is not locked up. Most common is to try and use the driveshaft inside the engine compartment.
rodsatheart is offline  
post #3 of 3 (permalink) Old 06-20-2019, 09:57 AM Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 2
Thanks, I will try this next. Should I try and put a wrench on the drive shaft? Or is there an easier way to turn it?
Bochico is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome