New battery terminal melting? ? - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-06-2014, 09:12 AM Thread Starter
Junior Member
 
Join Date: Jul 2014
Posts: 1
New battery terminal melting? ?

Hello all, I replaced my battery yesterday in my 1999 Yamaha 1200 gp. It kept making a clicking noise and would not start. I checked the connections and noticed that the positive terminal was melted. Has anyone ever seen this before?? I'm not sure if I need a new starter solenoid or what could cause this?? Any help would be greatly appreciated.
knykaza is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 3 (0 members and 3 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
battery terminal vx1100 caterpillar Yamaha Jetski 3 02-26-2017 08:40 AM
1996 SLT terminal board help! robeastunder Polaris Jetski 2 07-29-2011 09:02 AM
little black wire attached to the negative battery terminal 2strokeskis4me Kawasaki Jetski 0 07-04-2010 02:38 PM
Melting wire coating on 1995 Yahama Wave Raider Marko Yamaha Jetski 2 07-01-2010 02:24 AM
My ground to the motor is melting and smoking???? AAAtinting Kawasaki Jetski 2 07-10-2008 03:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome