07 rxp cavitation need help - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-18-2019, 08:45 PM Thread Starter
215
Junior Member
 
Join Date: Jun 2019
Posts: 4
07 rxp cavitation need help

Well I bought a new to me ski rxp 215. Noticed flooring it from a dead stop it will bounce on the rev limiter a couple times then pull real good after that. I put in a new wear ring trying to help it. It did not change it. The prop had some dings but nothing I haven't seen before, wasn't that bad. Wear do y'all recommend to go from here. Thanks.
215 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-19-2019, 05:35 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,889
Dock
Did you check the impeller to wear ring clearance ?
rodsatheart is online now  
post #3 of 6 (permalink) Old 06-19-2019, 08:42 AM Thread Starter
215
Junior Member
 
Join Date: Jun 2019
Posts: 4
Yes it is very close about the thickness of a piece of paper. Impeller has some marks on it but nothing I would think would cause anything. Almost wanting to put an impeller in it to try that.
215 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 06-20-2019, 05:26 AM
Super Moderator
 
rodsatheart's Avatar
 
Join Date: Oct 2014
Location: Mena, Ar.
Posts: 4,889
Dock
Needs to be checked with a feeler gauge. A piece of paper is about .003 thick. I have my Kawi stx1100 pump tight at .006, .002 tighter than oem. Avg seems to be about .010. Even .002 over tolerance can cause slipping.
It also could be that someone put a new impeller in it with a smaller pitch, or some mods have been done to increase power to the point that the stock pitch can't handle from a hard hole shot.
rodsatheart is online now  
post #5 of 6 (permalink) Old 06-20-2019, 07:14 AM Thread Starter
215
Junior Member
 
Join Date: Jun 2019
Posts: 4
Its 100% all stock. For now
215 is offline  
post #6 of 6 (permalink) Old 06-23-2019, 07:37 PM Thread Starter
215
Junior Member
 
Join Date: Jun 2019
Posts: 4
Think I might have found it, looks like it's going to be the carbon seal letting air in from the hull airating the pump.
215 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome