93 Seadoo Bombardier weird crank noise no start - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-05-2019, 08:27 PM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 1
93 Seadoo Bombardier weird crank noise no start

Hi all,

I have owned this 1993 Seadoo Bombardier GTX (3seater 581cc) for 3 years now,

i just put a brand new battery in today (7/5/2019) filled up the 2 stroke oil reservoir and topped off the gas (non ethanol tru Valero).

Took it out to the lake, started it up just fine, went out maybe 150 yards and it started sputtering like it wasnt getting any gas, tried to turn it around, giving it more gas, less gas, nothing worked and it died within 30 seconds of it starting to act up.

There i am in the middle of the lake with a dead jetski, i tried to re-start it but when i did it made a noise i have never heard it make before, it didnt go away and i had to swim it to shore.

I attached a video of the noise when i got back home, it cranks doesnt start, makes this awful noise (squealing like a pig?), not sure whats going on.

Hope to get some feedback and a possible solution, thank you!
youtube.com/watch?v=FJL__Qcb6-Y&feature=youtu.be
adamstain is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome