Trigger lag - PWC Forum: The best hang-out for Personal WaterCraft enthusiasts
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-31-2019, 01:30 AM Thread Starter
Junior Member
 
Join Date: Jul 2019
Posts: 1
Trigger lag

Hi,

Hoping to get advice on 2 issues. RXTX300RS 2016

Issue 1 - I seem to have a .05 second lag between hitting the accelerator and taking off, its not a cavitation but an actual delay in the signal being sent by the CPU, wear ring is new only 2 hours on it, I changed it thinking it may help but no result, impeller and bearings are A1, top speed is 128ks and no other performance issues. This lag is letting 260's get me off the start and is causing me to bounce out of the hole slowly, my ski will also not leap out of the water like all the other 260's and 300's that I ride with, it's very very annoying and I have no idea where to start looking to rectify it without being robbed by a mechanic! No doubt they will come up with some problem that costs $1500 to fix as always!

Issue 2 is minor but my rubber strap has unclipped on the right hand side of my intercooler and fallen to the back, any ideas on how to grab it without pulling out major components?

Thanks in advanced....
Dale Douglas is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PWC Forum: The best hang-out for Personal WaterCraft enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome