Personal Water Craft Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi,
New to this sport. 90 hours on each. One jetski hard to start. Yesterday, got stranded after 1 1/2 on water took a break and it wouldn't start back it turned but wouldn't start and also caused it to flood. Any suggestions?
Also, do these vehicles have fuel filters and if so where are they located?
Thanks
 

·
Registered
Joined
·
9 Posts
I have been having a problem on my '06 F-12x, it keeps blowing the coil fuse causing it not to get any spark, but still turns over, floods, etc. Check your fuses, they are locaed under neath the tool pack area. That whole black peice lifts up and there is a small fuse panel in there just above the jet at the rear.
 

·
Registered
Joined
·
9 Posts
I do not know of a fuel filter. I know when mine submerged i had water in the tank and it would sputter on the bottom end, i just topped off the tank, and rode it like hell and never had a problem once i ran that tank through. The ignition problem i think is just a short from having taken it apart to get the water out of the cylinders. Its sporadic, and only takes about a minute to fix even when i am stuck in the middle of the water.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6 (Edited)
It wasn't the fuse. Still won't start, anymore suggestions? To my knowledge it hasn't been flipped this season. We have a matching pair and just filled both up with high octane gas. The other ski is fine starts and runs fine.
 

·
Registered
Joined
·
2 Posts
A friend of mine has two aquatrax and he had a problem with one not starting when he bought it. He changed the spark plugs and everything was fine. Maybe try cleaning them and then replacing them if cleaning doesn't help. I'd check to see if you're getting a spark too before replacing the plugs because they're expensive if i remember right.
 

·
Registered
Joined
·
2 Posts
starter relay (35850-HW1-671)

i think its the starter and/or starter relay, i had the same problem, but i replaced the starter relay and it was back to ok.
 

·
Registered
Joined
·
285 Posts
Does anyone have or know where a online PDF shop manual is a guy could download? Looking at one of these could help all of us.
 

·
Registered
Joined
·
285 Posts
engine no starts. Caused by spark plugs, possible cause's faulty ignition coil or pulse generator. another cause is faulty idle air control valve. What has everyone tested? Do your machines have spark? or no spark? Give a little more info if you can and what you have tested. In here we need all the info we can get because we can't test the machine.
 

·
Registered
Joined
·
285 Posts
Just a note, Make sure when your done ridding to remove the seat so that the engine area can air out, this should help with corrosion to anything metal and electrical in the engine area. Just had a Ski in and it was corroded in the electrical box enough that it wouldn't run. After cleaning up connections started and ran fine.
I usually throw a old hair dryer in my engine area when done ridding and putting away for a little bit just to air it out if I have any water in the engine conpartment, doesn't have to be set on hi heat just enough to dry stuff up. And spray everything down with WD40 or CRC.
 
1 - 11 of 11 Posts
Top