Personal Water Craft Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I have this '04 F Turbo and an '05 R Turbo and for the past few rides I've noticed the F has a kind of roughness or vibration at cruise - say 30mph on smooth water. Sounds like it's under the seat toward the rear - not been too noticeable but today several times I could hit the throttle and it almost felt like ...gear or clutch slip would if it had either - it wasn't cavitation and I don't think it's the engine skipping. The turbo still spins up and hits hard like always. Ski has about 90 well cared for hours on it (oil/CRC/Flush/grease fitting/etc.). I put plugs in it about a 5hrs ago ..for the heck of it so don't believe it could be that.

Can someone explain what wear parts could cause this roughness? Impeller bearing, pump? or ? I'm not that familiar with these yet as they have been trouble free thus far. At idel with water hose attached I feel vibration on both the R and F at idle - in fact my R is rougher in the driveway but it's silky smooth on water.

hmmmmmmmmmm, any ideas?
 

·
Registered
Joined
·
285 Posts
Look up under the ski in the intake for the pump make sure their isn't anything wrapped around the shaft, string, fishing line or anything like that, and look at your prop too and make sure their isn't any nicks in it or chips out of it, as this would cause a imbalance and make for the vibration. Could possibly be the bearing going out. Their should be a grease zert towards the back of the ski once you remove the seat and your carrier for the tool kit and fire extinguisher. Pump some grease into it and see if this helps solve the problem. Keep us posted.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
Thanks, I figured out the problem. MACSBOOST CHIP. I removed it and noted the three separate leads had some corrosion on them and must have been causing an intermittent cut out condition. I put the wiring back stock and ... ran like a top. I have cleaned the leads and coated them with anti-corrosion grease and all is well. My engine compartment never gets wet, skis are stored in my garage but somehow, this happened.
 
1 - 3 of 3 Posts
Top