Personal Water Craft Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I just got 05 FX HO, changed oil, plugs, air filter, did all the neccesary maintenance stuff, took it to the lake, and couldn't start it for 10min. Finnaly when i had it running, it wouldn't idle i need constantly hold it reving. So it shutoff on me in the midle of the lake, tryed to start it till battery died, some good samaritan towned me to shore... Got home decided to check fuses, 3 AMP fuse was blown, replaced it, as soon as i tryed to crank it up i can see fuse blowing at the moment engine turns.... Engine starts after couple of attempts only and doesn't idle, fuse is blowing, i went through 3 of them.......HELP!!!!! Thank You
 

·
Registered
Joined
·
3,033 Posts
My Guess: Sounds like the ECU going bad with the hard starting, and bad idling, then ECU dies completely and you start blowing fuses because something is shorted. Could be something else shorted out (bilge pump, fuel pump), but I doubt it.
 

·
Registered
Joined
·
1 Posts
I just got 05 FX HO, changed oil, plugs, air filter, did all the neccesary maintenance stuff, took it to the lake, and couldn't start it for 10min. Finnaly when i had it running, it wouldn't idle i need constantly hold it reving. So it shutoff on me in the midle of the lake, tryed to start it till battery died, some good samaritan towned me to shore... Got home decided to check fuses, 3 AMP fuse was blown, replaced it, as soon as i tryed to crank it up i can see fuse blowing at the moment engine turns.... Engine starts after couple of attempts only and doesn't idle, fuse is blowing, i went through 3 of them.......HELP!!!!! Thank You
Ever figure out what the problem was, this is happening to my ski now.
 
1 - 3 of 3 Posts
Top