Personal Water Craft Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hey guys so my boss great guy says take his jet ski out and play arouund tells me it does 70 mph so get on it and is doing 30 mph tops..after awhile riding ski does 1-2 mph with thethrottle down so i went to honda dealer they tell us its impeller and housing, so we replace those items and change plugs and oil,,, 800 pesos later ,still same issue. Now we take to another dealer that can test in water the ski they tell us its the turbo seized and will cost 3500 buckos to fix issue so since were a bit tech inclined we decide to take turbo out very simple the clamp around the turbo and housing 3 lines and walla the turbos out dont remember if we took other stuff out but anyway onthe turbo is the big clump of deposit like oil and sut making a rock around the inner part of the turbine so we remove the grittyness that was holding the turbo from moving now the ski still does 30 mph so no we thing its gotta be the waste gate can anyone agree so far with all this
so if ur turbo is seized or thats what they tell you remember what we said but we want to know if we need a new waste gate ???? Thanks in advanced ....
 

·
Registered
Joined
·
5 Posts
Wow...did you really just acheive a world record with the worlds longest run-on sentence? LOL...

Sounds like it might be the wastegate at this point since you had so much crud in your turbo. Was it an oil leak that caked up, can you tell? Also, you made sure the turbine spins perfectly correct? You may also have caked lines, I would check those to keep the turbo cool otherwise its an uphill battle.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
:appl:NAHHHH THE LINES WERE ALL GOOD I JUST LUBED WITH ENTIRE CAN OF RUST PENETRATOR... I FORGET TO USE PERIODS LOL DONT LIKE EM
ANYHOW I LUBE THE WASTEGATE AND I ACTUALLY STARTED MOVING BETTER I COULD ACTUALLY MOVE THE ROD WITH MY HAND SO NOW I KNOW THAT ITS NOT STUCK (HOPEFULLY).I LEFT A VISE GRIP LOCKED ONTO ROD WITH THE GATE OPEN...:appl::appl::appl::appl:
I HOPE THIS WORK WILL REPLY IN A FEW DAYS SO LETS C
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Today we took her in tha water but same issue agggrrhhhhhhhhhhhhhh
we topped out @ 26 mph plz any help would be appreciated the waste gate didnt open like we thought..is there something inside the exhaust thats on the housing opens and closes..
Plz any advice would be appreciated
 

·
Registered
Joined
·
285 Posts
how many rps is the engine getting up to? If the wastegate didn't open you would have to much boost and it would go into limp mode. Can you turn the turbine on the intake side with your finger(engine off) does it turn freely? Is their any flashing codes? Remember the ski might be set in limit mode, like for your kids so you cant haul butt! has this been considered? if you need a owners manual in pdf just email me.
 

·
Registered
Joined
·
236 Posts
Make sure your 2" induction hoses are still attached at the intercooler inlet. Remove the turbo inlet hose and see if the compressor wheel spins at idle. If both are good buy a set of IR plugs from Advanced Auto Parts [$11 each].
Enjoy your toy.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
It was revving at a high of 5-6000 rpms nope no codes no warnings
it has gone into limp mode i guess when only 1-2 mphs can be max speed
we took off turbo from c clamp and it had a big deposit on the side thats attached to the housing....so thats what had turbo sticking but still same issues.. The limit mode light would be on ????
 

·
Registered
Joined
·
236 Posts
Usually if the turbo is shipping oil, it is a bad turbo. When mine failed it looked like a mosquito fogger. The Honda turbos, by being a lightly oiled ceramic ball bearing, do not have oil seals like a conventional turbo, just a piston ring type seal at both ends to keep exhaust/boost pressure out of the turbo.
I have also seen the heat shields behind the turbine wheel fail too.
 
1 - 9 of 9 Posts
Top