Personal Water Craft Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Gday guys,

My name is Kyle and I am from Down Under. My Ride is an 06 X2 and 2 days ago I took it out for a session of wave jumping at the beach.

After smashing around for about 30mins I hit a wave and lost it capsizing it. I swam to it, tipped it over and tried to start it. It didn't start, I assumed it was flooded with fuel. I waited with it for like 10mins tried again and nothing. At this point I thought I had fouled the plugs so I swam it back into shore(about 500m).

Once I had it beached I had to unfortunatly abandon it to get some tools from my car. On my return I found that a series of big waves had come in and pulled the craft back into the water, repeatedly dumping it on its side, filling the hull, my engine and carbs with water and sand. :appl::(.

I dragged it back out and drained everything ASAP, Pulled the plugs and started pumping water out of the engine. After 5mins my battery ran flat and I almost cried! I ended up having to get it towed back to the boat ramp so I could take it home.

Got home and immediatly started to crank the water back out but still couldn't get it started apart from a couple of misfires. At this point I suspected fuel, in turn I syphoned clean my tank (Had water and sand in it) of petrol filled with a fresh batch. I also blew clean all my fuel lines and the breather line, which had sand in it too! I cleaned the fuel filter screens and I also took off the Carbs gave them a rinse in petrol to shake loose any sand or shit that got sucked in.

Apon re-installing everything I can get it to tick over. Basically I have the choke on and turn it over, then choke off and turn it over, it fires up but revs like crazy only to die about 2 seconds after.

A couple more tries alternating between choke and no choke It fires up revs like crazy again, I pull the throttle and it dies, releasing the throttle it kicks back in revs like crazy again, then I can use the throttle to maintain a unhealthy high rev for about 10 seconds (with some water running through it) but when I release it it goes back to idle for like 2 seconds then dies.

So basically my problems are;
- Unable to idle.
- When it does turn over and fires up the revs are really high!
- Dies on WOT

This is so devistating to me because I bought it new like 2 months ago.

I suspect that there is some sand or shit in the carb blocking something. It's like I use the choke to flood carb with fuel, then fire it up, revs high and once the fuel that was in there from the choke is gone it dies.

Any help you guys can offer would be awsome, and some advice too!

- Kyle
 
1 - 2 of 2 Posts
Top