Personal Water Craft Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
95 750ss xi runnng great for a couple hours suddenly stop in the water.
checked the plugs looked good getting fuel , checked for spark no spark. the fuse is good. I never worked on a jet ski before so i dont know where the coils or what is, so can anyone help. I am very familiar with autos but no skis any help to fix spark probleom?
 

·
Registered
Joined
·
285 Posts
New Jet Ski Parts and Used Jetski Parts - Jetskiparts.com Go to this website, and plug in your information on the ski its simple, and it will give you a parts breakdown of your Ignition system, and the park #'s and pricing.
My guess is that the coil has gone bad? Hopefully not the Igniter, because their spendy. but if your fimilar with cars you can ohms test and do your voltage testing and be able to figure it out. Good Luck, please post what you come up with.
 

·
Registered
Joined
·
20 Posts
Haven't figured out why this is happening but sometimes i get spark and sometimes i don't. When i do it,s strong. Makes me throw the plug and wire. So i am ordering a new switch looks like a sealed deal. Yesterday it started fine this afternoon no start this eveing fired right up. With my problem i dont see the coil working so intermintly. i'm open to any other ideas
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top