Personal Water Craft Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
1996 Seadoo SPI Question - Help

I have a 1996 Seadoo Spi and it starts fine but when you press the throttle it starts to jump on plane and then boggs out. Some times it will stay running other times it won't. Also, if I kind of feather the throttle I can get it to full throttle but it will only go like 4 to 5 MPH. I just recently purchased this for my wife and I don't know the history as to when it was run last. Any ideas would be appreciated.
 

·
Registered
Joined
·
6 Posts
did you check

did you drain the old fuel ? did you change the spark plugs ? did the carbs set with fuel in them all winter ? sometimes the injector pump can leak oil past the crank seals when stored for a long time. does it smoke like a freight train ? exhaust leak will also do that. good luck !!!
 

·
Registered
Joined
·
6 Posts
my seadoo

i also removed the choke and installed a dual primer kit. starts so easy ! sorry it took so long for someone to respond. makes me wonder about this forum.
 

·
Registered
Joined
·
8 Posts
had the same issue with my 96 spx. found that it has old grey lines so those will have to be replaced, but as a quick fix for now, it will run fine when on RES fuel setting, not ON.

try switching to the RES fuel setting, could be a plugged fuel selector valve, thats what seems to be wriong with mine
 

·
Registered
Joined
·
6 Posts
did you drain the old fuel ? did you change the spark plugs ? did the carbs set with fuel in them all winter ? sometimes the injector pump can leak oil past the crank seals when stored for a long time. does it smoke like a freight train ? exhaust leak will also do that. good luck !!!
forgot to mention the rectifier/voltage regulators go bad and cause them to crap out at 4 to 5k rpm. I had it happen on mine. easy to replace cost about $70.
 

·
Registered
Joined
·
31 Posts
bogging/surging

MY 95 SPI started doing the same thing just today. Starts and runs great then wants to bog down or surge at speed. What is the deal with the grey fuel lines ??????????????????
 

·
Registered
Joined
·
6 Posts
gray fuel lines

The gray fuel lines get soft insde, and gell up. The fuel selectors go bad as well. If it pulls good to about 4,000 rpm then craps out, more than likely it is an issue with the rectifier / voltage regulator. Doesn't hurt to change the fuel lines out one by one. If you go into the electronic box in the front left side forward of the fuel tank, and unplug the red wire to the rectifier the battery won't charge but if the issue goes away change the rectifier.
 

·
Registered
Joined
·
31 Posts
bogging/surging

That is what happens but it just started. these are 95 SPI machines

It runs ok at idle and very slow but when you accelerate it starts to surge on and off.

I also have an issue with my other machine. I put in a full charged battery and run for an hour or so and its dead and have to keep jumping it. Should the machine be charging the battery while I'm running and if so is that the voltage reg that is probably bad?

Is there diagrams some where i can find to see where the regulator is and looks like?

Seems like every other year I have to put new batteries in these things.

Thanks
John
 

·
Registered
Joined
·
31 Posts
Ok another question..maybe dumb but..other than your battery going dead....anyway to check a rectifier??

PS...seems like your the only guy who frequents these forums...
 

·
Registered
Joined
·
6 Posts
Ok another question..maybe dumb but..other than your battery going dead....anyway to check a rectifier??

PS...seems like your the only guy who frequents these forums...
I reply when I recieve email suggesting a response to my post. If the battery doesn't charge it is likely the rectifier in the electric box r/s front on the side where all the wires go into. My previous post explains how to check if it is the problem with craping out. If the stator tests good, the rectifier is bad. I hope it's the regulator / rectifier, as it is only 70 bucks and takes 15 min. to swap out.
 

·
Registered
Joined
·
4 Posts
1996 seadoo spi idle

I have a 1996 seadoo spi that starts up fine but as soon as it starts the gas has to be bumped a little because it does not want to idle. It starts and idles fine out of the water but as soon as it is started in water you have to go because it doesnt like to sit around and idle any help would be appreciated thanks
 
1 - 16 of 16 Posts
Top