Personal Water Craft Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey all... new to this forum.

I have had my 98 GP760 for about 5 years now. It has been great. Minimal maintenance (battery every year), and always performed well for what I use it for.

Anyways, took it to the beach this past July for the first time ever. I usually ride it in fresh water lakes or brackish water rivers in my area in Hampton Roads, VA, so it never sees serious wave or sand. I hit some pretty serious waves and caught some nice air at the beach, and beached it several times (w/ Engine off, of course). It was a ton of fun down there.

Well, I just took it to the river and now it porpuses really bad once I get around 20mph. It used to do this at speeds approaching 45/50, and I was told to fix that I need an intake grate and ride plate upgrade. I never did that, as it wasn't worth the money to me. This porposing at 20mph is too serious though.

I have a feeling it might be my impeller that may be damaged, possibly causing cavitation, and impulse type thrusts making me porpose. The engine runs fine.

Any thoughts as to what might be happening, and How I can be sure I repair the right part. I looked in the impeller with the intake grate off, and the leading edge of the impeller blades were kinda knicked up. Don't know what the clearance should be between the outside of the impeller and the surrounding tube its in, but it seemed to be 'ok'.


Also, I'd like to do the work myself. Does anyone have a repair/service manual for this ski?

Does anyone know how difficult the impeller is to remove? Any special tools? Considerations? I'm an average joe on repairs, and usually figure stuff out with a few busted knuckles and a few dropped cuss words, but I've never done any jet system work before, so I'm kinda nervous about it.

Thanks in advance all.

FlynHokie
 
1 - 5 of 5 Posts
Top