Personal Water Craft Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
I own a 1998 GSX Limited, and recently my ski had about a 40% REDUX in power. The motor sounds fine, and if it wasn't from the loss of power I would have no clue anything was wrong. It does bog a bit during acceleration, but this is easily controlled by gently squeezing the throtlle vs yanking it. I recently took it to a dealer and they cleaned both Carbs and replaced the plugs. That had absolutely NO EFFECT. I feel like I was robbed blind. $450 and the ski is actually slightly worse than before it was in the shop. They did say that compression was that of a brand new motor. After I took got it back from the shop, I noticed that alot more water than normal was in the hull of the craft when I was done riding. (Which wasn't very long) Could this REDUX in power be caused by an exhaust leak? I have no clue what to do next...any help is greatly appreciated!!!

UPDATE: I filled my hull with water, and a leak became very evident. The coupling through which the speed sensor wiring enters the hull of the craft was completely removed. The dealer must have forgotten to put it back on. (I asked them to find out why my speedometer doesn't work) I still don't think this would cause the total loss of power though; just something to make me a bit more frustrated with the dealer that quite literally returned my ski in worse condition than when I gave it to them.
 
1 - 1 of 1 Posts
Top