Personal Water Craft Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I purchased a 2000 GTI off craigslist 3weekss ago, had no motor, had a brand new motor put it along with a carburetor.

The oil line has been capped off so I must pre-mix oil / gas.
First time riding the ski since the purchase.
I filled the get ski up with 93 octane, I put about 8 gallons of gas into the ski then gas started to spill over. I assumed that I was topped off.

I got on the water, turned the ski on and my gauge said empty. I assumed the gauge was broken. I was ridding for 2hrs, then it just fully stopped while my wife was driving right in the middle of the channel.

It was moving but super slow as if it was in nurtural. I assumed my sparkplugs were bad so I replaced the plugs I went to take it back out and it was doing the same thing again, I then tried to switch it from gas on to reserved gas. I then tried to choke the ski and then it died...


It wont turn on, I called the repair guy and he said sounds like a fuel delivery issue. He said the battery is dead but I'd like to get second opinion from other owners.


Thanks,
Joseph
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Can someone please help me out, the guy who's fixing the ski is dicking me around so need I say more I won't have my ski this weekend...I'm pissed because its been in the shop more then I've owned it...
 

·
Registered
Joined
·
811 Posts
Hey guy I feel for ya, let me try to understand some things. Does the ski start up on the trailer? If no did you try a little starting fluid? The fact that it ran for two hours says it should still run unless the gas was lean on oil and the rings got hot and scuffed the cylinders. What was your gas to oil ratio? Lastly could you have sucked up any debris?:confused:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
OUTLAW, I used 93 octane gas with 3 ounces of PWC synthetic oil per gallon of gas.
It's a brand new motor & the repair guy has been screwing me around ever since I purchased the ski for 950$ and the motor for 750$... It took me 3 weeks to get the ski back, I finally get it out on the water and It breaks down and I had to swim it back to shore!

I bring it to him four days ago and every day he rushes me off the phone tells me it'll be done tomorrow. He's told me that 3 days in a row so today I said will it be done for this weekend (had plans with the wife, its her birthday on Monday but was going to take the Ski out Saturday / Sunday)

He told me not to bank on it, I highly doubt its going to get fixed because he said to me " I have 20 ski's waiting to get fixed, your waiting in the line as well) I'm a new owner for ski's and I finally buy one and he talked me into buying his since it'll be like having a brand new ski....

Since having the ski its been in the shop more then its been in my driveway. I'm very upset!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Here's a update; I called the police to recover my ski today around 1:45 PM. The owner of the shop thats ran out of his house wasn't there, he was " fixing my ski on the lake " I think he sunk my ski today, I brought it to another local shop & the guy feels he sunk the ski since water is inside the carborator case & sandwas under the seat areas.

I'm going to bring the ski to another shop on Tuesday but from what I am told it drives good for 20mins then breaks up...

I'm so getting fed up at this point, I just wanted a ski that ran perfectly fine but I guess thats what I get for buying a ski off craigslist....

If anyone has any advice to give me please help!
 
1 - 6 of 6 Posts
Top