Personal Water Craft Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I recently purchased this Cream Puff and Is my 1st PWC. It runs slick as a button off the trailer. After pulling a knee board around the lake 6 or 8 times and I shut it down it will not start back up a lot of times until it sets 15 or 20 minutes. Watching the fuel filter while attempting to start it, It dont seem like it is pumping fuel through it. After it sets for a while it starts back up and runs like a champ for as long as you want to ride it. Any Ideas????
Thanks in Advance.:)
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
Sorry, Failed to mention that I put a new aftermarket filter from NAPA on it. This thing runs like a sewing machine. Just hard to crank after riding it a while. Is there something that could be heating up and keeping it from starting? Module or something?
 

·
Registered
Joined
·
1 Posts
I recently purchased this Cream Puff and Is my 1st PWC. It runs slick as a button off the trailer. After pulling a knee board around the lake 6 or 8 times and I shut it down it will not start back up a lot of times until it sets 15 or 20 minutes. Watching the fuel filter while attempting to start it, It dont seem like it is pumping fuel through it. After it sets for a while it starts back up and runs like a champ for as long as you want to ride it. Any Ideas????
Thanks in Advance.:)
Screen in fuel tank may be clogged picking up crap, then falls back to bottom after sitting. Plus,,,put correct fuel filter on it.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top