Personal Water Craft Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
New to jet skis and this forum. Just brought home a 2001 gp1200 that hasn't been started in 3-4 months. The engine is seized, plugs are out, no movement in the pistons, just a slight jerking. Have put Pb blaster down the spark plug holes hoping to break the pistons loose. Nothing yet, going to go down and see after I'm done here. Any sugestions to get this engine spinning? Thanks, Eino.
 

·
Premium Member
Joined
·
354 Posts
Are you sure the thing hasn't had some major engine issue with it and that is why it is not starting? My ski's have sat for more than 3 or 4 months in between start ups and other than turning over a little longer, they have always fired right up. (Note to self. Weather has been cold, start up jet ski's tomorrow!)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Don't really know anything about the history on this machine. Looks rough but clean on the inside of the engine compartment. Is there a possibility that the pump and drive shaft are not moving and the engine is not the problem?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Turns out the wear ring in the impeller housing corroded and bulged out and bound up the impeller. Going to order a new housing with a replaceable wear ring. Now I can't get the engine to fire. Doesn't appear to have spark at the plugs, but I have the exhaust off with those 2 electrical connections unhooked, does that not let me start the engine?
 
1 - 6 of 6 Posts
Top