Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello Everyone

I just bought a 2001 Kawasaki STX 900 JetSki that has a fuel issue. The Jetski was sold to me disassembled, mainly the carburetor was out. So while it was out i cleaned it and reinstalled a rebuild kit however, i did not change any of the screw adjustments as i was not sure. I put everything back together and tried to start it but for some reason no fuel is getting into the engine. The engine will start for a few seconds if i drop some fuel into the carb inlets on top but will die again.

There are 3 hoses going to the back at the fuel pump. (Grey Air hose, Return Hose, ON Hose)

On the pump one fitting says IN, the other says OUT and one has Infinity sign i am assuming that would be the air inlet.

The 2 lines coming from the fuel tank are Return and ON,

I have connected the reserve hose to the out fitting on the pump and the ON hose to the IN Fitting but i am still not getting fuel from the tank to the carbs. Also am i suppose to prime the pump if so how can i do it?
 

·
Registered
Joined
·
16 Posts
Had this issue, not sure if the solution is the same but, I had to adjust the idle screws, they are from the factory plugged, I drilled a small hole in the plug and stuck a pick in it to pop it out. Backed them out about 1/4 turn started right up.
 

·
Registered
Joined
·
16 Posts
If I remember correctly they are located like right above the oil line ports. Could be wrong. If you don't find them I could check.
 
1 - 4 of 4 Posts
Top