Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Ran the ski Sunday for the first time this year. Left the landing and in five minutes it shut down like it was out of gas, started back up and it shut back down. Wife pulled me to sand bar on river and I took the seat off and the smoke was in the engine compartment, smelled like oil. No fire, started back up and would only idle for a few seconds. It would crank but smoked out of the engine compartment. Any help with this problem would be greatly apprecited, thanks TRL:dunno:
 

·
Registered
Joined
·
73 Posts
Check all of your exhaust system connections.

Coupler from the exhaust pipe to the waterbox.

Everything from the waterbox to the termination point where it exits the hull.
 

·
BORN TO FISH NOT CATCH
Joined
·
1,512 Posts
problem

TRL24 said:
Ran the ski Sunday for the first time this year. Left the landing and in five minutes it shut down like it was out of gas, started back up and it shut back down. Wife pulled me to sand bar on river and I took the seat off and the smoke was in the engine compartment, smelled like oil. No fire, started back up and would only idle for a few seconds. It would crank but smoked out of the engine compartment. Any help with this problem would be greatly apprecited, thanks TRL:dunno:

has to be exhaust leak

fire it up without the cover on and look and listen u will hear it
 

·
Registered
Joined
·
15 Posts
exhaust leak

this should be in the polaris forum :)
here is a quick way to check if you have and exhaust leak. fogging oil. it makes thick blue smoke. it is easy to detect where the leak is. it could be a be resonator that is buried and you cannot tell other than removing it.
 
1 - 4 of 4 Posts
Top