Personal Water Craft Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello, I'm new here, but have been lurking around for a while.

I currently own a beautiful 2001 ZXI1100 and I love everything about it!

I just dewinterized it and took it out for a ride. Took a long while to start but it finally did. Couple of changes:

I've noticed that it's a huge gas guzzler. Is this normal??

Also, when I was reaching the bottom of the engine bay, i noticed a good sized pool of oil there. Could it be a main seal leak or the oil tank itself? I doubt it would be the tank because if it is, then the pool would be bigger so I'm thinking it's a small, but significant leak in one of the seals.

Lastly, after owning this PWC for a while, I decided to look into aftermarket parts and rebuild the engine. Anything to make it better and faster while increasing the fuel efficency? I looked into getting K&N Flame Arrestors and thought it would be a good idea. For the arrestors, do I need adapters or I can just plug it into the flame controllers?

Thanks for reading and I hope to get great information from here :)
 

·
Registered
Joined
·
2 Posts
yeah, they are kind of like minature tug boats when it comes to fuel, but if you think your 2001 1100 stx di is bad on fuel, you should have owned one of the pre 2000 jet skis, you would have thought you had a big block chevy in it. By the way I just joined this site a few minutes ago and am wondering if there is a fuse or somewhere, because mine runs fine, but I just lost all the readouts on the front dash, no fuel, no speedometer, no anything, but it seems to run ok, have not put it in water yet since I discovered this yesterday, let me know if you run across any ideas. I bought 2 new kawasaki jet skis back in 2001 , the 1100 and an ultra 130, this is the first apparent major problem that I have had in 8 years.
 
1 - 2 of 2 Posts
Top