Personal Water Craft Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
My brother in law just bought a 2002 Seadoo RXDI with 29 hours on the clock. It starts fine and idles great. When I accelerate it has great power for about 5-10 seconds. Then a beep sound and it goes completely dead. The digital dash even goes off. Then I have to wait about a minute and it starts up. I set the display on temp and tried it. Its not getting hot. The temp is at 70 when it dies. It has fuel injection and I was wondering if it is like a car. Will the computer store trouble codes? It almost seems like the computer is shutting it down. I hope we can figure this out. It is his first PWC. He rode my yamaha GP1200 and loved it. It was a hard decision to buy the ski. It ran fine when he tested it.. Any help would be great.

Budman
 

·
Registered
Joined
·
4 Posts
I had the exact same problem when I had my 03 rxdi. Turned out it was a loose connection on the battery. Take a good look at those connections. Kinda a PITA to tighten but you will figure it out. Hope its as easy as that.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
We did check the battery connections. Thats interesting because the person he bought it from said that he didn't think the battery was good so he put a different one in after they test rode it. I think we will try a different battery. Thanks for the response.
Any other ideas if this doesn't work?

Budman
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
He got it back from the seasoo dealer friday. The voltage regulator was burned out. $150.00 for the part and it will take 2 weeks to get it. They did the computer scan for free though. It should be up and running before the snow falls.
Budman
 
1 - 5 of 5 Posts
Top