Personal Water Craft Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Has anyone ever encountered this? I was driving along and the 2002 Virage sputtered some and then stopped completely. I noticed the display shoed the fule at the bottom and the oil at the bottom marks (which I had just filled up a half hour ago) and it seemed only part of the display was functioning. When I tried to start the machine it clicked once and wouldn't turn over, I tried again and same thing it clicked like the battery was dead.

I put a new battery in a week ago because it seemed like it would draw down from the display always being on but it had worked fine since the new battery. I towed it in and after a hour or so tried it again. NOw the box above the battery will click pretty loud but the starter won't try. (I think this is the starter relay switch). I will test the battery to make sure it is above the 12 amps or whatever it takes to start the machine any other ideas?
 

·
Registered
Joined
·
4 Posts
Mine did the same thing when I tried to start it , just went click the relay is good. its the sarter one way to test it is to back the motor up! should be a cover that you need to remove on the drive shaft that has a greae zerk on it .
Then turn shaft , hit the start and should turn over if stops after you do this then you need a new starter . Thats my problem its under the motor, So Iam taking it to the dealer to fix, found one on line for 74.95 labor is 300.00
 
1 - 3 of 3 Posts
Top