Personal Water Craft Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I recently bought this jetski that was “ready to ride” I took it to the lake and dropped it in with full tank of gas. I left the boat dock to head to the beach where my family was a couple hundred yards away and by the time I got there the gas tank plummeted to empty and started beeping at me. It ran great by the way. So when I got to the beach I learned that if I click the “mode” button on my gauges it stopped to noise from the beeping but still reads empty and warning. But I checked the fuel level and it was fine. So I continued to ride it. About twenty minutes in I noticed the throttle was losing power intermittently until ultimately it wouldn’t go above 5 mph. And I noticed white smoke coming out the back. Not bellowing but still concerning. Also a very strong smell of gas. Every time I stop the jet ski and let it sit for a few minutes and start it again, it will run fine for a few minutes and than it happens all over again. And the fuel gauge will sometimes slowly climb up and/or down. Has anyone had this problem or does anyone know what I can do to fix this? In my research I’ve discovered it could be fouled plug, bad gas, fuel sending unit, or unfortunately the head gasket.. I’m praying this thing isn’t totaled beyond repair as I went in over my head when scraping funds to buy it to try to be a super dad of which I feel I ultimately failed on Father’s Day although i was able to see some smiles on my children when they were enjoying something they had never done before no matter how short lived it was
 
1 - 1 of 1 Posts
Top