Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I need some help I have a 2004 Aquatrax f12x, and right now it will not start or turn over at all. It was running on land for a little bit, and all of a sudden it just shut off, and it did not feel as though it had overheated. Now after I have changed the oil and put it together, It will not start. Did I trip a switch or the ECU or anything? How can I reset this?
 

·
Registered
Joined
·
236 Posts
Are you sure the battery terminals are tight and the battery charged? Check your fuses. It may be the main relay that is hidden in the rear beside the big black electrical box. You should not run them more than 30-40 seconds without cooling water. Always shut off the water before you shut down the engine or you might hydrolock the engine.
 

·
Registered
Joined
·
285 Posts
You had to of disconnected something when you changed the oil, take your time and look around and I'm sure you will find it. Hope you didn't run it with out oil? it will lock up. If I understand everything your saying
 

·
Registered
Joined
·
17 Posts
First of all, you should not run the engine on land too long, it is not good for the it (I was told 2 or 3 min max), even with water running. I had the same problem, I was flushing and cleaning one of my Jetskis, turned off, and then did not want to start again. It was a 5 amp fuse that was completely rotten. so take a look in the fuse box. Good luck
 
1 - 4 of 4 Posts
Top