Personal Water Craft Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Aloha from Hawaii,
I own a 2005 Honda Aquatrax F-12X and the speedometer no long reads correctly. Normally i would read about 60 or so at full trottle. hovever now it reads only at 23-25 MPH. I have no idea where to start to attempt to fix the problem. Please let me know what can be done to fix the problem.
Much Mahalo.
 

·
Registered
Joined
·
11 Posts
Speedo wrong

I have the same problem with my 2004 Aquatrax. I know how they work. It is based on a wheel turning with magnets on it. As it passes it kind of works like a small generator and depending on how much voltage or amperage it passes it shows up on the speedo. A loose connection is probably going to be the culprit and I would suspect it will be near the wheel which is mounted near the jet drive pump at the back of the ski.
 

·
Registered
Joined
·
1 Posts
Incorrect Speedo Reading - Resolved

I had the same problem recently after a visit to Lake Havasu. The first day the speed was correct then the next it was off by at least 25+ mph. I checked the paddle wheel thinking it was jammed w/weeds - no issue, it was spinning fine. Asked the repair dept. at the local dealer, they claimed it was weeds - no luck. I decided to drop the paddle assembly from the ride plate - it's easy (4 phillips screws) and low and behold a small pebble fell out of the intake for the paddle wheel. This limited the water flowing to the paddle wheel causing the erroneous reading. Try this it just may work - Good Luck!!!
 
1 - 4 of 4 Posts
Top