Personal Water Craft Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently put my ski in the water after having it witerized, new plugs & oil change. It starts & runs great, but when at or near full throttle, it will occasionally die (everything cuts off, rpm/speed dial sticks at ~60 mph). It just cuts off and after coming to a stop, it will start right up.

Could it be a faulty kill switch or loose battery connection?

Any other ideas?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
any codes coming up on cluster gauge?
No alarm codes at the time of cut off. I did have the low voltage light come on for a second when I started it for the first time one day, but it started up fine and didn't come back on for the rest of the day, so I didn't pay it much mind.
 

·
Registered
Joined
·
3,033 Posts
I recently put my ski in the water after having it witerized, new plugs & oil change. It starts & runs great, but when at or near full throttle, it will occasionally die (everything cuts off, rpm/speed dial sticks at ~60 mph). It just cuts off and after coming to a stop, it will start right up.

Could it be a faulty kill switch or loose battery connection?

Any other ideas?
Could it be fuel starvation? Possible dirt or restriction in the fuel injector..........letting it get enough fuel at low speeds, but not enough at full throttle? I think you can take the injector apart pretty easily and check it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Think I found problem

One of the battery cables was loose. After tightening it up, I have not had it cut off since.
 
1 - 5 of 5 Posts
Top