Personal Water Craft Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Help! I puchased a 2007 Honda r12x several weeks ago. 30 hours non salt. A screw in plug on the side of the impellar housing came out and the engine stopped pumping water. It did what is was supposed to do. It gave me the overheating light and shut the engine down to lower rpms. The prg-fi also came on and would not rev up. After making the repair on the housing it still would not rev up under pressure? Also after checking the oil it was milky indicating water. I changed the oil and carried to the Honda dealer hoping he could clear the codes and everything would be fine.I picked it up and put it back in the water and now it will not even run? Any insights on this I am fairly mechanical Someone also told me i would have to change the oil 5 times to get the water out? Is there a sensor that would keep the engine from cranking because there is water in the oil? If i cant fix it i need a mechanic in the Ga. area to help without charging $4000 to repair a ski that i paid $4000 for. I priced the pump housing that got damaged at $300 and purchased one that was perfect for $49. Any Help??
 

·
Registered
Joined
·
236 Posts
Help! I puchased a 2007 Honda r12x several weeks ago. 30 hours non salt. A screw in plug on the side of the impellar housing came out and the engine stopped pumping water. It did what is was supposed to do. It gave me the overheating light and shut the engine down to lower rpms. The prg-fi also came on and would not rev up. After making the repair on the housing it still would not rev up under pressure? Also after checking the oil it was milky indicating water. I changed the oil and carried to the Honda dealer hoping he could clear the codes and everything would be fine.I picked it up and put it back in the water and now it will not even run? Any insights on this I am fairly mechanical Someone also told me i would have to change the oil 5 times to get the water out? Is there a sensor that would keep the engine from cranking because there is water in the oil? If i cant fix it i need a mechanic in the Ga. area to help without charging $4000 to repair a ski that i paid $4000 for. I priced the pump housing that got damaged at $300 and purchased one that was perfect for $49. Any Help??
Sounds like you smoked your head gasket or cracked your exhaust manifold.
Do you have an oil sucker to remove the oil/water from the engine? What part of Georgia are you in?
There is a lot of good info on PWCTODAY.COM in the Honda section on water infiltration problems.
 
1 - 2 of 2 Posts
Top