Personal Water Craft Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,
I am having trouble with my 2008 Aquatrax F-15-X. It has very few hours on it. When safety lanyard is clipped in, the warning light starts blinking for a couple minutes along with a couple other symbols. It cranks over no problem. After a minute or two, the display shuts off and does not crank over. I honestly think it’s something with electronics not allowing the ski to start. I think if can reset the electronics and get rid of warning light the ski will run just fine. The most recent mechanic I brought it too told me he was getting fuel into the fuel rack. I have brought the machine to mechanics in the past but seems like no one wants to work on it or fix the issue. I was also told they cannot find parts for this machine as it is too old. Not really sure if I buy that or not. I am not a PWC expert by any means but I truly believe it’s an electronic issue. The machine was properly flushed and stored away properly after last use many years ago. Also I’ve been trying to start machine on trailer without any water. Does the machine sense there is no water and that can be a possibility? Thank you in advance to anyone who responds and can possibly help me out!
Thank you
 

·
Registered
Joined
·
11 Posts
Buy a factory service manual, save time and money, they are about $30. Yes, there is a reset procedure for the display and comp and no, water should not be turned on until after engine is running and stable.
 
1 - 3 of 3 Posts
Top