Personal Water Craft Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Well I bought in Florida on (July 26 2010) while on vacation in OBX a 2010 Wake Pro 215 2 hours after using it to break it in it developed a starting problem after I would shut it down it would not restart. After it sat for 1 full day went back to ski and it would start and seemed ok after another hour same thing. At tthat time I was still on vacation luckily I still had use of my TRUSTY 07 GTI130 SE. Well fast forward to last Sat took it out one more time to see what would happen after riding for several hours CHECK engine came on IBR light came on and it would go 30MPH (LIMP HOME MODE). Has anyone had problems with their Pro or am I the only one. BTW it has 5 hours on it now. :( For a unit to cost this much and ALREADY have problems .. It is going ot the dealer here in MD this weekend.

 

·
Registered
Joined
·
811 Posts
Hey there, sorry to hear that you are having trouble with your Seadoo Wake Pro. You're the first person I have seen with a problem with the Wake Pro. A lot of problems with these skis is that some dealers over look or make mistakes during programing. If something isn't turned on or programed right it messes with the ECU. Also the ignition system is different from the old ones. You have to press the start button before plugging in the lanyard to wake it up. Then you will hear two beeps then start.

I personally own three Seadoos. The 2009 Rxt-IS is by far the most complex and closest to yours. I personally love it.

I jet ski in MD also.
 

·
Registered
Joined
·
35 Posts
Let us know what the problem is. My 2010 RXT X has been perfect with the exception of a damaged wear ring - from riding in shallow water. I did meet a guy in my marina who had to haul his 2010 RXT X out because it wouldn't shift into neutral or reverse after starting it (5hrs) and he had to return to the dock in limp mode. Other than that, most people I talk to haven't had problems with their Sea Doos
 

·
Registered
Joined
·
19 Posts
Discussion Starter #4
Let us know what the problem is. My 2010 RXT X has been perfect with the exception of a damaged wear ring - from riding in shallow water. I did meet a guy in my marina who had to haul his 2010 RXT X out because it wouldn't shift into neutral or reverse after starting it (5hrs) and he had to return to the dock in limp mode. Other than that, most people I talk to haven't had problems with their Sea Doos

That is excatly what I am hearing from most other Sea Doo owners I meet @ the water. It has been @ the dealer since Aug 28 and they have not looked @ it yet. Still waiting to find out what is wrong with it.
 

·
Registered
Joined
·
811 Posts
That is excatly what I am hearing from most other Sea Doo owners I meet @ the water. It has been @ the dealer since Aug 28 and they have not looked @ it yet. Still waiting to find out what is wrong with it.
I talked to my Seadoo dealer about your problem. He said to make sure you have gotten any software updates flashed to your ski. He said there has some issues especially to the RXT-X 260.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Well it has been @ the dealer and they looked @ it but the service guy told me they don't know what is wrong IE bad module ECM etc etc. So It should be finished by next season I guess. I am a technician on european cars and when they start using more and more computers in cars they have problems these new skis with the brakes is nice when it works but knowing what I know now I think I should NOT have bought this ski being it is the FIRST year for this drive by wire technology.:mad::mad:
 

·
Registered
Joined
·
811 Posts
Well it has been @ the dealer and they looked @ it but the service guy told me they don't know what is wrong IE bad module ECM etc etc. So It should be finished by next season I guess. I am a technician on european cars and when they start using more and more computers in cars they have problems these new skis with the brakes is nice when it works but knowing what I know now I think I should NOT have bought this ski being it is the FIRST year for this drive by wire technology.:mad::mad:
First of all this is not the first year for drive by wire technology. Last year was. I own the 2009 RXT-IS 255. Which has more electronics than a Wake Pro. The IS suspension is just part of it. I have never had an electrical problem at all. All the new technology works perfectly. Partly because I have the best Seadoo dealer in the area. They fix other dealer's fiascos all the time. If it were me, and the dealer told me they didn't know whats wrong?????:dunno:I would got to another dealer right away.:mad:
 

·
Registered
Joined
·
19 Posts
Discussion Starter #8
First of all this is not the first year for drive by wire technology. Last year was. I own the 2009 RXT-IS 255. Which has more electronics than a Wake Pro. The IS suspension is just part of it. I have never had an electrical problem at all. All the new technology works perfectly. Partly because I have the best Seadoo dealer in the area. They fix other dealer's fiascos all the time. If it were me, and the dealer told me they didn't know whats wrong?????:dunno:I would got to another dealer right away.:mad:

Ahh okay they just got it wrong on my ski then. What dealer are you going to and where r they? The dealer told me they are waiting wor dfrom Sea Doo as to what needs to be done. But if I dont get this resolved I will look into taking it some where else. And as far as your IS having more electronics I did not think that your ski has SKI mode though and the wake does??
 

·
Registered
Joined
·
811 Posts
Ahh okay they just got it wrong on my ski then. What dealer are you going to and where r they? The dealer told me they are waiting wor dfrom Sea Doo as to what needs to be done. But if I dont get this resolved I will look into taking it some where else. And as far as your IS having more electronics I did not think that your ski has SKI mode though and the wake does??
Correct I don't have "Ski mode" similar to cruise control w/memory. But the electronics in the IS suspension are way more complex and involved than that.

My dealer's name is J & J Watercraft. Jim is the owner and C.J. is the lead tech. (302) 655-4957

I mean really if I brought my car to you and you said , " Dunno whats wrong " would you feel like WTF?
 

·
Registered
Joined
·
23 Posts
More problems with the Wake Pro 215

Correct I don't have "Ski mode" similar to cruise control w/memory. But the electronics in the IS suspension are way more complex and involved than that.

My dealer's name is J & J Watercraft. Jim is the owner and C.J. is the lead tech. (302) 655-4957

I mean really if I brought my car to you and you said , " Dunno whats wrong " would you feel like WTF?
Yes, I've had a few problems as well. The IBR just stopped working once, but then fired up OK when I turned the motor off and then on again. Also, in Ski Mode 1 it starts off accelerating for about one or two seconds, then the revs die for another 2 or 3 seconds, and then finally it begins to accelerate smoothly to the chosen programmed speed. The dealer can't find anything wrong, but he did not try it with e.g., a kneeboarder attached to the back. (Didn't have one handy.)
 
1 - 10 of 10 Posts
Top