Personal Water Craft Forum banner

2020 kawasaki stx 160 power lost

4161 Views 13 Replies 10 Participants Last post by  hawkella
I ran my jet ski for about one hour and notice that lost power then remove the key and wait like one minute to start up again and run strong again for a while and the same issue. Anyone knows whats going on?
1 - 14 of 14 Posts
I ran my jet ski for about one hour and notice that lost power then remove the key and wait like one minute to start up again and run strong again for a while and the same issue. Anyone knows whats going on?
It seem the fuel supply problem. Please check the fuel tank ventilation hose and valve. You can test in simple way by loosen the fuel tank cap.
good luck!
Thanks I will and hope that's the problem I don't go to the dealer yet because they are always expensive even on small issues.
Did you figure out your Kawasaki power issue Mines doing the same thing
I ran my jet ski for about one hour and notice that lost power then remove the key and wait like one minute to start up again and run strong again for a while and the same issue. Anyone knows whats going on?
Did you figure it out ?
I have two 2020 STX 160 and they are both doing the same thing. I’m baffled. I do have over 100 hours on them already but wtf ? I’ve done the maintenance correctly and on time. Any help please
Did you figure out your Kawasaki power issue Mines doing the same thing
Did you figure it out ?
I have two 2020 STX 160 and they are both doing the same thing. I’m baffled. I do have over 100 hours on them already but wtf ? I’ve done the maintenance correctly and on time. Any help please
Did you figure it out ?
I have two 2020 STX 160 and they are both doing the same thing. I’m baffled. I do have over 100 hours on them already but wtf ? I’ve done the maintenance correctly and on time. Any help please

Hello

Dealer drained gas and changed fuel filter per kawasaki recommendation... have only taken out once since they did that.. no issue but I don't think that is it.. because it should do that as soon as started if it was gas/fuel filter issue.... so I don't think it will be it...
  • Like
Reactions: 2
Are you saying that you don’t think draining the fuel and changing fuel filter is the fix? Is it a fuel filter or fuel water separator? Always wondering if there is one or should I add a fuel water separator. No issues with my skis but they only have 13 hours. 👍 keep us posted
Did anyone find a solution to this problem?
I have 4 and all loosing power, surging. I’m keen to find out
¿Alguien encontró una solución a este problema?
Tengo 4 y todos pierden potencia, se disparan. tengo muchas ganas de averiguarlo
[/COTIZAR]
Hola, tengo 3 con el mismo problema, he cambiado bomba de gasolina y nada, sigue igual, estoy desesperado. Alguien me puede ayudar??
Anyone ever figure out a cause to the above problem. I am experiencing it now. I changed spark plugs today and added Sea Foam additive. Jet ski runs fairly well at low speeds but when you give it full throttle starts to cut out. Did not use to do that..
As someone said before something about changing the fuel filter, draining the tank etc. my fuel filters had some gunk in them, drained the tanks replaced the filters and now they have been running fine, 20 hours since doing this and all still running well.
Hello

Dealer drained gas and changed fuel filter per kawasaki recommendation... have only taken out once since they did that.. no issue but I don't think that is it.. because it should do that as soon as started if it was gas/fuel filter issue.... so I don't think it will be it...
I have a 2021 STX 160, less than 35 hours on it. EXACT SAME PROBLEMS last yr after about 15 hrs it wd run fine then after 10-15 mins of avg riding start to sputter out, dealer had it for 5 months, could not figure out prblem, sent to another deal and they changed fuel filter, and ran fine this yr. After about 15-18 hrs this yr, same exact problems. Back to the dealer, service manger tells me he doesnt think its the fuel filter cause it appears very clean. Zero Answers, 13K$ machine im paying for and not riding
Was it a hard job to replace the filters. It looks fairly extensive
1 - 14 of 14 Posts
Top