Personal Water Craft Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Im trying to get my buddies js 440 running, i believe its a 79. im new to jet skis so im having trouble diagnosing the problem. Here what i got. Good spark and compression on both cylinders, Check valve seems to be working fine and all the fuel lines look fine. Put new plugs and gas in it. It will fire a little but wont run for more than a second or two after i take my finger off the starter. doesnt seem to matter if the choke is on or off. I set the carb needles to one turn on the high and 5/8 on the low which seemed to help a little now it will run a little longer with the trottle craked but it will rev up a little and cut out a couple times and eventually die. The motor was seized up a little because it was sitting outside for several months. i poured motor oil down the spark plug holes which freed it up but i did not know then that it would go into the crank case, nor did i know that it wasn't supposed to have oil down there (car guy). On thing i noticed was that there was a little pressure built up in the flywheel cover upon un screwing the cap. Im thinking about checking the timing and rebuilding the carb. other than this i dont know what to do. Im assuming the crank seals are good because if they were leaking i would have had oil leaking out and dont bad crank seals create a lean condition? Im assuming its not lean because of the amount of smoke that comes out of the exhaust, seems to be too much, quite a bit of thick white smoke. anybody have any thoughts on whats wrong?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #2
Oh and im not sue if all the oil in the crank case is out of there, i took the top of the exhaust off, with the water lines on it, and was able to get a little out of it, is there a better way to get it out?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
Well i rebuilt the carb, it was in pretty bad shape. The engine still doesn't run well though. It definatley improved though. Now it will idle for several seconds, eratically, before it eventually stalls. The motor will not build Rpm's, doesn't matter where i hold the throttle. I Also Tried many different low speed carb setiings, i worked from a really lean setting and turned it out in 1/8th turn increments some settings seemed to work better, but there weren't any major differences. One thing i noticed was gasoline leaking from the cap where all of the hoses connect to the tank, im assuming the tank needs to be air tight. I am wondering if an air leak in the tank could make the ski run as poorly as it is? Any other thoughts on what to check next?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #6
Check valve seems good, only allows air to pass in one direction. Im Gonna try throwing another carb of my working 440 on it, seems to me that its not getting enough fuel. ill throw the check valve off mine on it too and ill let you know how it does. only other thing i can think of is timing or something with the ignition. thanks for the advice.
 

·
Registered
Joined
·
144 Posts
you did say it was seized didn't you. could be a lack of compression.
 

·
Registered
Joined
·
144 Posts
could be a lack of compression. Sorry didn't catch the compression thing while reading through the original post.
 
1 - 9 of 9 Posts
Top