Personal Water Craft Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
i have just put on a brand new 44mm mariner carb on my 91 kawi 550. I hooked the gas lines just how they were with the stock carb. I also installed a primer in the ski. First the primer was not sucking fuel and then I finally got it to suck gas but it would burn that fuel up from the primer and then die. I cant seem to get it to suck gas from the tank. any suggestions?
 

·
Registered
Joined
·
111 Posts
you might still have air in the fuel line. The primer line may be full but the main fuel line still may have air in it. I may be way off b/c I dont understand your exact situation but the first ride every summer on my JS440 (with a primer) I have to pump and pump and pump the primer before I get anything and then get the engine to rumble several times before it primes the fuel line and fills the carb and sustains itself.

might also check the diaphragms in the vacuum pump on the carb. if its a new carb there's a small chance you got one with a manufacturing defect and its got a pinhole or something in there so it cant draw a vacuum.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
you might still have air in the fuel line. The primer line may be full but the main fuel line still may have air in it. I may be way off b/c I dont understand your exact situation but the first ride every summer on my JS440 (with a primer) I have to pump and pump and pump the primer before I get anything and then get the engine to rumble several times before it primes the fuel line and fills the carb and sustains itself.

might also check the diaphragms in the vacuum pump on the carb. if its a new carb there's a small chance you got one with a manufacturing defect and its got a pinhole or something in there so it cant draw a vacuum.
YEAH i moved around the hoses to get it to suck fuel in the primer finally, but it will suck fuel and then it like stops sucking. sometimes it does sometimes it doesnt. Ive had it rumbling a bunch of times but i cant get a vacuum. in one of the hoses is this little round device with two wires coming off it leading to the electric box. what is this some kind of pump?
 

·
Registered
Joined
·
111 Posts
the round thing on the side of the carb is a vacuum operated fuel pump. I'm not sure if its got any wires on it or not. I'm not sure off hand what the round thing you're talking about is.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
the round thing on the side of the carb is a vacuum operated fuel pump. I'm not sure if its got any wires on it or not. I'm not sure off hand what the round thing you're talking about is.
No im talking about this round thing that is in the middle of the fuel line going to the carb. Its in the line before the carb. it had to wires coming off it. Idk what it does.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
No Fuel

SHOULD I JUST CUT THE WIRES OR WILL IT MESS ANYTHING UP IN THE ELECTRIC BOX?
i DID AWAY WITH THE REV LIMITER UN HOOKED IT AND RAN THE FUEL LINES STRAIGHT TO THE CARB AND I STILL CAN NOT GET IT TO SUCK FUEL. mY PRIMER IS SUCKING AIR AND A LITTLE BIT OF GAS. I DONT HAVE A FUEL ON OFF SWITCH OR RESERVE. THIS IS REALLY FRUSTRATING . I CANT FIND THE PROBLEM.
 
1 - 10 of 10 Posts
Top