Personal Water Craft Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Hi,

I have a 550sx thats been stored for a while in my shed. I remember fireing it up about 6 months ago, apart from the carb needing a rebuild it was fine. My SJ is in for a rebuild so i wanted something to muck about on until its done.

Ok, so i charged up a good battery and went to fire it up and what i got is just a clicking in the electrical box. Cleaned up all the lead and terminals and still nothing but the clicking. I then swapped the starter button with a spare to test that and no different. Next i swapped the magnetic switch over with a spare again no difference. I then swapped all the leads i.e. battery earth, battery live and starter lead with new. No difference. Then swapped the voltage regulator & stop switch relay. Again nothing. The starter is brand new and still under warranty so im sure its not that.

Starting to get more than a little frustrated. Has anyone got any other suggestions as to what to try????? Please??????


Just thought i would add that the stater is out and i can turn the engine over by hand.
 

·
Registered
Joined
·
11 Posts
You've done a lot of things, most of them good ideas. I would put the starter back in, pull the plugs, and take the red lead off of the starter, extend it with a jumper to the pos. terminal of the battery. just tap it, the starter should fire over the motor with the plugs out. If this works, I would check the starter solenoid, but you already swapped that. I wouldn't bother with the start stop switch, since you heard the solenoid clicking when you pressed it, its good. with all the extra parts you have you should find the problem.
 
1 - 2 of 2 Posts
Top