Personal Water Craft Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So, basically we did a full rebuilt on a 550 sx that have been sitting for 13 years on our garage, 2 days ago we went riding and it felt normal, idles agressive as always and rode quite well, but at the end of the afternoon the idle felt less agressive and it ran slower, basically it became less agressive at all , so today we went riding and from the beginning felt not as powerful or agressive as last time.
2 days ago we were running premium fuel and today we filled it with regular fuel, does it change anything ?
Also its having batteries problems, can it decrease the power or anything related?
 

·
Read Only
Joined
·
5,059 Posts
If the battery is not staying charged, yes it will affect it. A bad battery can cause the system to work to hard. Might do a compression test to make sure nothing going on there, and did you clean the fuel system and rebuild the carb ?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
We did, full rebuilt and everything, the only initial issue was battery, first day ran perfectly, 2 days later felt different
 

·
Registered
Joined
·
30 Posts
Did you run it in with sightly more oil then standard at first and take it easy for the first hour or so as the rings wear in, or did you just go flat out from the start and revved the crap out of it with no wear in period ?
Did you assemble the magneto correctly, tightened all the screws and bolts as the magneto does the timing and if it slips a little it will be firing incorrectly and one a two stroke that really effects it, also do you have a small air leak in the exhaust maybe ?
I had a 550SX and mine at one time went as though it was running out of fuel and I found it was a broken joiner on the power pipe.
So many things it can be when people do their own rebuilds as we have no clue if you even know which end of a screw driver to use, so giving advice on what could be wrong after a rebuild, it's more like what may not be wrong after amateurs rebuild a ski :)
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Its not our own build, 2 mechanics took it to their shop, and it was there for like 6 months, i would say all the exaust pipe and bolts are on well state, on the other hand, i didnt rode it at first, but i guess the guy first warmed it and then rode i'd say.
I kinda believe its a battery thing or the gasoline too, but we never know...
 
1 - 7 of 7 Posts
Top