Personal Water Craft Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I recently picked up a project 1990 550sx and I’ve been having some issues with it running in water. To start I rebuilt the engine with ideal compression. Stock exauhst. Recently rebuilt carb. Pop off pressure was about 10psi in carb. New seals everywhere in engine intake and exauhst. I believe it’s a Makuni 44mm round body but I’ve looked at a couple pictures and seems there is two different styles? Anyways it starts up with the primer and will only stay running (out of water) if I give it a little gas. Otherwise it slowly bogs down and may idle for a second or two. In the water it starts up with the primer and runs for about 2-4 seconds before it bogs down. I try to give it throttle but it won’t rev up. It seems to be starved of gas and or badly tuned (whiched i still haven’t figured out how to do properly). Any tips would be greatly appreciated on what may be going wrong! I’ve also been told that these carbs are junk and to upgrade haha. Thank you for any help
 

·
Premium Member
Joined
·
5,059 Posts
Need to know if it's a BN or SBN. They use different pop off's. The BN has a very large round fuel pump on the side, and the SBN has a square fuel pump and the regulator cover on the other side is positioned so it looks like a diamond.
 

·
Premium Member
Joined
·
5,059 Posts
Try setting the mixture screws to these settings. pilot 1 5/16 turns out, low 1 1/16 turns out, high 15/16 turn out. If that jets it started, then there's more on the water tuning that needs to be done.
 
1 - 5 of 5 Posts
Top