Personal Water Craft Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi,
I was out on my 650 SX last week, everything was going well untill the ski cut out and would not start again.
After removing the hood and inspected i found i had no spark at all.
I stripped the cut off switch and cleaned to no success.

Can someone guide me in a better direction into were i should be looking? Someone told me it might have slipped out of timing, i dont know how true this is?

Any advice would help at the moment..

Kind regards
 

·
Registered
Joined
·
20 Posts
I would check the e box. Pull the two bolts that hold the electric connector for the start/stopswitch and the connector for the engine electric. I have never had a 650 but I am assuming that they have similar electric connections as the550. Behind there is a 4 or5 pin connector . see that they are clean and dry. I would say if it is not ovbious in there than u prob have a broken wire some where.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Hi, thanks for that,

I cant seem to find a broken wire and it all seems clean and dry. Someone has suggested i change the Coil?
 

·
Registered
Joined
·
144 Posts
Hi, thanks for that,

I cant seem to find a broken wire and it all seems clean and dry. Someone has suggested i change the Coil?

Get yourself a cheap ohm meter and start checking the continuity and ohms resistance between the wires. There is a section in your manual that details what wires to check and what resistance you should be reading between them for each item.

Don't start buying electrical components until you determine which one is required. It'll get really expensive in a hurry, and will probably be really frustrating as well. From my experience it will be the exciter coil on the stator assembly behind the flywheel. They are available online at about $45.00. Don't try to get it rewound if that is the problem, it never works properly.

Hope this helps.

If you don't have a manual let me know and I can scan the pages for you later when I get home.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Hi,

I have just ordered a manual as i dont have one at the moment.
I checked the continuity on the coil and it showed open circuit... no continuity..??
This is bugging me now!!

Thanks for your help.
 
1 - 5 of 5 Posts
Top