Personal Water Craft Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hey guys new to PWC and ill start out by saying i love these things. i started off with the polaris 650 sl i bought for $200 and i also just bought a honda aquatrax f12. they are both so fun but i would like your help in keeping my rides running. the problem is when i got the 650sl it had all the wrong spark plugs in it and eventually stopped running. i replaced these and found some plug cable issues which i also fixed. now it runs great but it seems that once its warmed up it will shut off. any help would greatly be appretiated
thank you:confused
 

·
Registered
Joined
·
13 Posts
Un-strap the battery and computer from the hull. Then I would pull apart the computer/fuse box to see if water or anything else is wrong with the wiring.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
so I found a blown fuse in my water filled wire box but when I pulled the fuse the wire came with it. Its an orange wire with a fuse and was located in the corner. does anyone know of a wiring diagram I could use for this? Or just some pictures would be greatly appretiated.
Thanks
 

·
Registered
Joined
·
13 Posts
dominus- when I get back to the house this weekend I can get a diagram from my Seloc manual and try to scan the wiring diagram pages for the whole ski. I just didn't the book with me in the field so I apologize I can get it quicker.
 

·
Registered
Joined
·
13 Posts
From the back of the Seloc manual the Orange wire is the ground for the stator. In the CDI box there should not be an orange wire. I see an Orange wire for the engine ground and temp buzzer but not apart of the box.

I'll try to scan my book and I apologize the late response.
 
1 - 10 of 10 Posts
Top