Personal Water Craft Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Had some issues with perfect 650 after accidentally cross wiring battery at start of season and then sinking her....

Anyway, figured out the volt reg fried, the stator was having issues intermittent dead stop at idle and the spark arrest / plug box... went ahead and just ordered new parts

pulled flywheel found stator was really gone, noticed on flywheel a coiled metal (pieces) like a gasket tore apart... anyway clymers and kawasaki dont have anything in their service manuals that looks like this, cleaned the flywheel looked great, put the new stator in, greased, loctite, put the new o ring sealed ready...

PUlled the cdi box or on the 650 the electrical box (note they dont make or sell the elect gasket anymore (babbits), SBT, nothing...

put new voltage reg in

put new spark box in

for the love of >>>> I cant remember the wiring

VOLT REG has Y,Y, BL, BL&Y, O

Stator has BLUE, BL&RED, BL, W

Spark Box has Y, Y, O, BL&RED, BL

the 2 black grounds with (0) connectors not an issue

WHY ARE THEY NOT COLOR CODED? DOES ANYONE KNOW THE SEQUENCE CAN SEND A PICT? OR DETAILED WIRING (Clymers has it in terms of ohm load per wire WTF?)

VoltREG
BL goes to ?
1st Y goes to ?
Bl & Red goes to sparkbox BL&RED?
2nd Y goes to ?
O goes to O on relay?

Stator wiring

oh crap just lost here....

Help

[email protected]

I can email you a pict would like to be riding sat... its ready to go aside from the wiring
 
1 - 3 of 3 Posts
Top