Personal Water Craft Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
This is my buddy's ski. He just got it running the first time this year. We hooked up the garden hose, fired it up, turned on the water... I turned the idle up a bit to keep it running... a couple minutes later it sounded like it was about to die, so i told him to goose it. He did and it reved up and wouldn't slow back down when he let off. He pulled the dead man key, still running. He pulled the plug wires, STILL RUNNING!! So i shut the choke butterfly and it slowly came to a hault. WTF??
 

·
Registered
Joined
·
4 Posts
Yeah its not weired... Its the high compresion of the engine, the spark plugs glow red making it react like a spark plug. Also 2 strokes can also start up on there own if there hot.
 

·
Registered
Joined
·
3 Posts
What happened to my 1995 Polaris SLT 750?

I was crusing at about 40% power, when suddenly the engine quit. I tried to restart, but the engine was siezed. Using channel lock pliers, I was able to rotate & unlock the engine at the jet pump coupler.

I removed the 3 sparkplugs & was able to spin the rngine freely with the starter. Also, all 3 cyl have sufficient compression. After reinstalling the 3 plugs & wires, I tried to start the engine, but it just sputters like it is out of time & it also tries to sieze again.

I feel something is trying to come loose in front of engine, in the timing gear mechanism?? Has anyone out there experienced same situation & pinpoint my problem before I tear into the engine?
Thanks
 
1 - 7 of 7 Posts
Top